Ships Nostalgia banner

1 - 5 of 5 Posts

·
Registered
Joined
·
6,179 Posts
Discussion Starter #1
I have a Nikon Coolpix 5200 & recently spilt some water over the camera, I dried the outside & every thing was working OK. After leaving the camera for 2 days I loaded battery & SD card & attempted to switch on.......Nothing has happened since, the battery still holds charge & I managed to download the pics off the SD card. I have got it covered on my house contents but before getting in touch with the insurer is there anything I could do to get it working again? It has been in a towel on the radiator for 2 days, I checked twice to see if it would work but without success. Yes I did put the battery back in too! & it was fully charged. Thank you in advance. (Thumb)
 

·
Registered
Joined
·
636 Posts
You may be outta luck, Pat! There is so much electronic circuitry in these things and you've probably shorted the lot. Happened to me this year in the States when I rolled a kayak! Had my Canon G3 in my pocket, say no more. Pretty water-shy these little guys. Good job I was only using it as a backup to my main digi gear. Tried the hairdryer treatment to no avail. Lot of money involved getting it repaired (even if Canon would repair it after 3 years!) so now it sits at home with the rest of the 'ancient' equipment!!
 

·
Registered
Joined
·
6,179 Posts
Discussion Starter #5
I'll get in touch with the insurance people after the weekend. Luckily none of the pics on the SD card were damaged. I have a few cameras so will take better care next time? (Thumb) Thanks guys!
 
1 - 5 of 5 Posts
Top